1 |
Name: ascend |
2 |
Summary: ASCEND modelling environment |
3 |
Version: 0.9.5.94 |
4 |
|
5 |
# Use release 0.* so that other users can do patch releases with a higher number |
6 |
# and still have the update occur automatically. |
7 |
Release: 0 |
8 |
|
9 |
License: GPL |
10 |
Group: Applications/Engineering |
11 |
Source: ascend-0.9.5.94.tar.bz2 |
12 |
URL: http://ascend.cheme.cmu.edu/ |
13 |
|
14 |
Prefix: %{_prefix} |
15 |
Packager: John Pye |
16 |
Vendor: Carnegie Mellon University |
17 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
18 |
|
19 |
BuildRequires: python >= 2.4, python-devel |
20 |
BuildRequires: scons >= 0.96.1 |
21 |
BuildRequires: bison, flex |
22 |
BuildRequires: swig >= 1.3.24 |
23 |
BuildRequires: desktop-file-utils |
24 |
BuildRequires: tk-devel < 8.5 |
25 |
BuildRequires: tcl-devel < 8.5 |
26 |
BuildRequires: tktable < 2.10, tktable >= 2.8 |
27 |
BuildRequires: compat-gcc-32-g77 == 3.2.3 |
28 |
|
29 |
Requires: python >= 2.4 |
30 |
Requires: pygtk2 >= 2.6 |
31 |
Requires: pygtk2-libglade |
32 |
Requires: python-matplotlib |
33 |
Requires: python-numeric |
34 |
Requires: gtksourceview |
35 |
Requires: xgraph >= 11 |
36 |
|
37 |
%description |
38 |
ASCEND IV is both a large-scale object-oriented mathematical |
39 |
modeling environment and a strongly typed mathematical modeling |
40 |
language. Although ASCEND has primarily been developed by Chemical |
41 |
Engineers, great care has been exercised to assure that it is |
42 |
domain independent. ASCEND can support modeling activities in |
43 |
fields from Architecture to (computational) Zoology. |
44 |
|
45 |
#%package -n ascend-python |
46 |
#Version: 0.9.5.94 |
47 |
#Summary: PyGTK user interface for ASCEND |
48 |
#Group: Applications/Engineering |
49 |
# |
50 |
#%description -n ascend-python |
51 |
#PyGTK user interface for ASCEND. This is a new interface that follows GNOME |
52 |
#human interface guidelines as closely as possible. It does not as yet provide |
53 |
#access to all of the ASCEND functionality provided by the Tcl/Tk interface. |
54 |
# |
55 |
#%package -n ascend-tcltk |
56 |
#Version: 0.9.5.94 |
57 |
#Summary: Tcl/Tk user interface for ASCEND |
58 |
#Group: Applications/Engineering |
59 |
# |
60 |
#%description -n ascend-tcltk |
61 |
#Tcl/Tk user interface for ASCEND. This is the original ASCEND IV interface |
62 |
#and is a more complete and mature interface than the alternative PyGTK |
63 |
#interface. Use this interface if you need to use ASCEND *.a4s files or other |
64 |
#functionality not provided by the PyGTK interface. |
65 |
|
66 |
%prep |
67 |
%setup -q -n ascend-0.9.5.94 |
68 |
|
69 |
%build |
70 |
scons %{?_smp_mflags} DEFAULT_ASCENDLIBRARY=%{_datadir}/ascend/models \ |
71 |
INSTALL_ROOT=%{buildroot} \ |
72 |
INSTALL_PREFIX=%{_prefix} \ |
73 |
INSTALL_SHARE=%{_datadir} \ |
74 |
INSTALL_BIN=%{_bindir} \ |
75 |
INSTALL_INCLUDE=%{_includedir} \ |
76 |
F2C_LIBPATH=/usr/lib/gcc-lib/i386-redhat-linux/3.2.3/ WITH_SOLVERS=QRSLV,LSOD,CMSLV pygtk tcltk |
77 |
|
78 |
%install |
79 |
rm -rf %{buildroot} |
80 |
scons %{?_smp_mflags} install |
81 |
|
82 |
# Install menu entry for PyGTK interface, gtksourceview syntax highlighting, and MIME definition |
83 |
pushd pygtk/gnome |
84 |
install -m 644 -D ascend.desktop %{buildroot}/%{_datadir}/applications/ascend.desktop |
85 |
install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/ascend-app.png |
86 |
install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend.png |
87 |
install -m 644 -D ascend.xml %{buildroot}/%{_datadir}/mime/packages/ascend.xml |
88 |
install -m 644 -D ascend.lang %{buildroot}/%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang |
89 |
popd |
90 |
|
91 |
# Install menu entry for Tcl/Tk interface |
92 |
pushd tcltk/gnome |
93 |
install -m 644 -D ascend4.desktop %{buildroot}/%{_datadir}/applications/ascend4.desktop |
94 |
install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/ascend4-app.png |
95 |
install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend4.png |
96 |
popd |
97 |
|
98 |
%clean |
99 |
rm -rf %{buildroot} |
100 |
|
101 |
%post |
102 |
update-desktop-database |
103 |
update-mime-database /usr/share/mime |
104 |
|
105 |
%postun |
106 |
update-desktop-database |
107 |
update-mime-database /usr/share/mime |
108 |
|
109 |
%files |
110 |
%defattr(-, root, root) |
111 |
%doc INSTALL.txt LICENSE.txt |
112 |
%{_datadir}/ascend/models |
113 |
%{_libdir}/libascend.so |
114 |
%{_datadir}/mime/packages/ascend.xml |
115 |
%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang |
116 |
|
117 |
# %package -n ascend-python |
118 |
%{_bindir}/ascend |
119 |
%{_datadir}/ascend/*.py |
120 |
%{_datadir}/ascend/*.pyc |
121 |
%{_datadir}/ascend/*.pyo |
122 |
%{_datadir}/ascend/glade |
123 |
%{_datadir}/ascend/_ascpy.so |
124 |
%{_datadir}/applications/ascend.desktop |
125 |
%{_datadir}/icons/ascend-app.png |
126 |
%{_datadir}/icons/hicolor/64x64/ascend.png |
127 |
|
128 |
# %package -n ascend-tcltk |
129 |
%{_bindir}/ascend4 |
130 |
%{_datadir}/ascend/tcltk |
131 |
%{_libdir}/libascendtcl.so |
132 |
%{_datadir}/applications/ascend4.desktop |
133 |
%{_datadir}/icons/ascend4-app.png |
134 |
%{_datadir}/icons/hicolor/64x64/ascend4.png |
135 |
|
136 |
%changelog |
137 |
* Thu Jun 01 2006 John Pye <john.pye@student.unsw.edu.au> |
138 |
- Add Tcl/Tk interface to GNOME menu |
139 |
|
140 |
* Tue May 02 2006 John Pye <john.pye@student.unsw.edu.au> |
141 |
- Break out ascend-core, ascend-python and ascend-tcltk packages. |
142 |
|
143 |
* Mon Apr 24 2006 John Pye <john.pye@student.unsw.edu.au> |
144 |
- Modified for removed dir in pygtk source hierachy |
145 |
|
146 |
* Thu Apr 04 2006 John Pye <john.pye@student.unsw.edu.au> |
147 |
- First RPM package for new SCons build |