/[ascend]/trunk/ascend.spec
ViewVC logotype

Contents of /trunk/ascend.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 656 - (show annotations) (download)
Fri Jun 2 06:36:32 2006 UTC (18 years, 4 months ago) by johnpye
File size: 4638 byte(s)
Removed dependency on ccache.
Added RELEASE flag to allow BuildBot to control RPM versions.
1 Name: ascend
2 Summary: ASCEND modelling environment
3 Version: 0.9.5.93
4
5 # Use release 0.* so that other users can do patch releases with a higher number
6 Release: 0
7
8 License: GPL
9 Group: Applications/Engineering
10 Source: ascend-0.9.5.93.tar.bz2
11 URL: http://ascend.cheme.cmu.edu/
12
13 Prefix: %{_prefix}
14 Packager: John Pye
15 Vendor: Carnegie Mellon University
16 BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18 BuildRequires: python >= 2.4, python-devel
19 BuildRequires: scons >= 0.96.1
20 BuildRequires: bison, flex
21 BuildRequires: swig >= 1.3.24
22 BuildRequires: desktop-file-utils
23 BuildRequires: tk-devel < 8.5
24 BuildRequires: tcl-devel < 8.5
25 BuildRequires: tktable < 2.10, tktable >= 2.8
26
27 Requires: python >= 2.4
28 Requires: pygtk2 >= 2.6
29 Requires: pygtk2-libglade
30 Requires: python-matplotlib
31 Requires: python-numeric
32 Requires: gtksourceview
33 Requires: xgraph >= 11
34
35 %description
36 ASCEND IV is both a large-scale object-oriented mathematical
37 modeling environment and a strongly typed mathematical modeling
38 language. Although ASCEND has primarily been developed by Chemical
39 Engineers, great care has been exercised to assure that it is
40 domain independent. ASCEND can support modeling activities in
41 fields from Architecture to (computational) Zoology.
42
43 #%package -n ascend-python
44 #Version: 0.9.5.93
45 #Summary: PyGTK user interface for ASCEND
46 #Group: Applications/Engineering
47 #
48 #%description -n ascend-python
49 #PyGTK user interface for ASCEND. This is a new interface that follows GNOME
50 #human interface guidelines as closely as possible. It does not as yet provide
51 #access to all of the ASCEND functionality provided by the Tcl/Tk interface.
52 #
53 #%package -n ascend-tcltk
54 #Version: 0.9.5.93
55 #Summary: Tcl/Tk user interface for ASCEND
56 #Group: Applications/Engineering
57 #
58 #%description -n ascend-tcltk
59 #Tcl/Tk user interface for ASCEND. This is the original ASCEND IV interface
60 #and is a more complete and mature interface than the alternative PyGTK
61 #interface. Use this interface if you need to use ASCEND *.a4s files or other
62 #functionality not provided by the PyGTK interface.
63
64 %prep
65 %setup -q -n ascend-0.9.5.93
66
67 %build
68 scons %{?_smp_mflags} DEFAULT_ASCENDLIBRARY=%{_datadir}/ascend/models INSTALL_ROOT=%{buildroot} INSTALL_PREFIX=%{_prefix} INSTALL_SHARE=%{_datadir} INSTALL_BIN=%{_bindir} INSTALL_INCLUDE=%{_includedir} TCL=/usr TCL_LIB=tcl8.4 TK_LIB=tk8.4 WITH_SOLVERS=QRSLV,LSOD,CMSLV pygtk tcltk
69
70 %install
71 rm -rf %{buildroot}
72 scons %{?_smp_mflags} install
73
74 # Install menu entry for PyGTK interface, gtksourceview syntax highlighting, and MIME definition
75 pushd pygtk/gnome
76 install -m 644 -D ascend.desktop %{buildroot}/%{_datadir}/applications/ascend.desktop
77 install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/ascend-app.png
78 install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend.png
79 install -m 644 -D ascend.xml %{buildroot}/%{_datadir}/mime/packages/ascend.xml
80 install -m 644 -D ascend.lang %{buildroot}/%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang
81 popd
82
83 # Install menu entry for Tcl/Tk interface
84 pushd tcltk/gnome
85 install -m 644 -D ascend4.desktop %{buildroot}/%{_datadir}/applications/ascend4.desktop
86 install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/ascend4-app.png
87 install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend4.png
88 popd
89
90 %clean
91 rm -rf %{buildroot}
92
93 %post
94 update-desktop-database
95 update-mime-database /usr/share/mime
96
97 %postun
98 update-desktop-database
99 update-mime-database /usr/share/mime
100
101 %files
102 %defattr(-, root, root)
103 %doc INSTALL.txt LICENSE.txt
104 %{_datadir}/ascend/models
105 %{_libdir}/libascend.so
106 %{_datadir}/mime/packages/ascend.xml
107 %{_datadir}/gtksourceview-1.0/language-specs/ascend.lang
108
109 # %package -n ascend-python
110 %{_bindir}/ascend
111 %{_datadir}/ascend/*.py
112 %{_datadir}/ascend/*.pyc
113 %{_datadir}/ascend/*.pyo
114 %{_datadir}/ascend/glade
115 %{_datadir}/ascend/_ascpy.so
116 %{_datadir}/applications/ascend.desktop
117 %{_datadir}/icons/ascend-app.png
118 %{_datadir}/icons/hicolor/64x64/ascend.png
119
120 # %package -n ascend-tcltk
121 %{_bindir}/ascend4
122 %{_datadir}/ascend/tcltk
123 %{_libdir}/libascendtcl.so
124 %{_datadir}/applications/ascend4.desktop
125 %{_datadir}/icons/ascend4-app.png
126 %{_datadir}/icons/hicolor/64x64/ascend4.png
127
128 %changelog
129 * Thu Jun 01 2006 John Pye <john.pye@student.unsw.edu.au>
130 - Add Tcl/Tk interface to GNOME menu
131
132 * Tue May 02 2006 John Pye <john.pye@student.unsw.edu.au>
133 - Break out ascend-core, ascend-python and ascend-tcltk packages.
134
135 * Mon Apr 24 2006 John Pye <john.pye@student.unsw.edu.au>
136 - Modified for removed dir in pygtk source hierachy
137
138 * Thu Apr 04 2006 John Pye <john.pye@student.unsw.edu.au>
139 - First RPM package for new SCons build

john.pye@anu.edu.au
ViewVC Help
Powered by ViewVC 1.1.22