1 |
Name: ascend |
2 |
Summary: ASCEND modelling environment |
3 |
Version: 0.9.5.93 |
4 |
|
5 |
# Use release "0" so that distro-released versions will override ours. |
6 |
Release: 0.jdpipe |
7 |
|
8 |
License: GPL |
9 |
Group: Applications/Engineering |
10 |
Source: ascend-0.9.5.93.tar.bz2 |
11 |
URL: http://ascend.cheme.cmu.edu/ |
12 |
|
13 |
Prefix: %{_prefix} |
14 |
Packager: John Pye |
15 |
Vendor: Carnegie Mellon University |
16 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
17 |
|
18 |
BuildRequires: python >= 2.4, python-devel |
19 |
BuildRequires: scons >= 0.96.1 |
20 |
BuildRequires: bison, flex |
21 |
BuildRequires: swig >= 1.3.24 |
22 |
BuildRequires: desktop-file-utils |
23 |
BuildRequires: tk-devel < 8.5 |
24 |
BuildRequires: tcl-devel < 8.5 |
25 |
BuildRequires: tktable < 2.10, tktable >= 2.8 |
26 |
BuildRequires: ccache |
27 |
|
28 |
Requires: python >= 2.4 |
29 |
Requires: pygtk2 >= 2.6 |
30 |
Requires: pygtk2-libglade |
31 |
Requires: python-matplotlib |
32 |
Requires: python-numeric |
33 |
Requires: gtksourceview |
34 |
Requires: xgraph >= 11 |
35 |
|
36 |
%description |
37 |
ASCEND IV is both a large-scale object-oriented mathematical |
38 |
modeling environment and a strongly typed mathematical modeling |
39 |
language. Although ASCEND has primarily been developed by Chemical |
40 |
Engineers, great care has been exercised to assure that it is |
41 |
domain independent. ASCEND can support modeling activities in |
42 |
fields from Architecture to (computational) Zoology. |
43 |
|
44 |
#%package -n ascend-python |
45 |
#Version: 0.9.5.93 |
46 |
#Summary: PyGTK user interface for ASCEND |
47 |
#Group: Applications/Engineering |
48 |
# |
49 |
#%description -n ascend-python |
50 |
#PyGTK user interface for ASCEND. This is a new interface that follows GNOME |
51 |
#human interface guidelines as closely as possible. It does not as yet provide |
52 |
#access to all of the ASCEND functionality provided by the Tcl/Tk interface. |
53 |
# |
54 |
#%package -n ascend-tcltk |
55 |
#Version: 0.9.5.93 |
56 |
#Summary: Tcl/Tk user interface for ASCEND |
57 |
#Group: Applications/Engineering |
58 |
# |
59 |
#%description -n ascend-tcltk |
60 |
#Tcl/Tk user interface for ASCEND. This is the original ASCEND IV interface |
61 |
#and is a more complete and mature interface than the alternative PyGTK |
62 |
#interface. Use this interface if you need to use ASCEND *.a4s files or other |
63 |
#functionality not provided by the PyGTK interface. |
64 |
|
65 |
%prep |
66 |
%setup -q -n ascend-0.9.5.93 |
67 |
|
68 |
%build |
69 |
scons %{?_smp_mflags} CC="ccache gcc" CXX="ccache g++" DEFAULT_ASCENDLIBRARY=%{_datadir}/ascend/models INSTALL_ROOT=%{buildroot} INSTALL_PREFIX=%{_prefix} INSTALL_SHARE=%{_datadir} INSTALL_BIN=%{_bindir} INSTALL_INCLUDE=%{_includedir} TCL=/usr TCL_LIB=tcl8.4 TK_LIB=tk8.4 WITH_SOLVERS=QRSLV,LSOD,CMSLV pygtk tcltk |
70 |
|
71 |
%install |
72 |
rm -rf %{buildroot} |
73 |
scons %{?_smp_mflags} install |
74 |
|
75 |
# Install menu entry for PyGTK interface, gtksourceview syntax highlighting, and MIME definition |
76 |
pushd pygtk/gnome |
77 |
install -m 644 -D ascend.desktop %{buildroot}/%{_datadir}/applications/ascend.desktop |
78 |
install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/ascend-app.png |
79 |
install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend.png |
80 |
install -m 644 -D ascend.xml %{buildroot}/%{_datadir}/mime/packages/ascend.xml |
81 |
install -m 644 -D ascend.lang %{buildroot}/%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang |
82 |
popd |
83 |
|
84 |
# Install menu entry for Tcl/Tk interface |
85 |
pushd tcltk/gnome |
86 |
install -m 644 -D ascend4.desktop %{buildroot}/%{_datadir}/applications/ascend4.desktop |
87 |
install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/ascend4-app.png |
88 |
install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend4.png |
89 |
popd |
90 |
|
91 |
%clean |
92 |
rm -rf %{buildroot} |
93 |
|
94 |
%post |
95 |
update-desktop-database |
96 |
update-mime-database /usr/share/mime |
97 |
|
98 |
%postun |
99 |
update-desktop-database |
100 |
update-mime-database /usr/share/mime |
101 |
|
102 |
%files |
103 |
%defattr(-, root, root) |
104 |
%doc INSTALL.txt LICENSE.txt |
105 |
%{_datadir}/ascend/models |
106 |
%{_libdir}/libascend.so |
107 |
%{_datadir}/mime/packages/ascend.xml |
108 |
%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang |
109 |
|
110 |
# %package -n ascend-python |
111 |
%{_bindir}/ascend |
112 |
%{_datadir}/ascend/*.py |
113 |
%{_datadir}/ascend/*.pyc |
114 |
%{_datadir}/ascend/*.pyo |
115 |
%{_datadir}/ascend/glade |
116 |
%{_datadir}/ascend/_ascpy.so |
117 |
%{_datadir}/applications/ascend.desktop |
118 |
%{_datadir}/icons/ascend-app.png |
119 |
%{_datadir}/icons/hicolor/64x64/ascend.png |
120 |
|
121 |
# %package -n ascend-tcltk |
122 |
%{_bindir}/ascend4 |
123 |
%{_datadir}/ascend/tcltk |
124 |
%{_libdir}/libascendtcl.so |
125 |
%{_datadir}/applications/ascend4.desktop |
126 |
%{_datadir}/icons/ascend4-app.png |
127 |
%{_datadir}/icons/hicolor/64x64/ascend4.png |
128 |
|
129 |
%changelog |
130 |
* Thu Jun 01 2006 John Pye <john.pye@student.unsw.edu.au> |
131 |
- Add Tcl/Tk interface to GNOME menu |
132 |
|
133 |
* Tue May 02 2006 John Pye <john.pye@student.unsw.edu.au> |
134 |
- Break out ascend-core, ascend-python and ascend-tcltk packages. |
135 |
|
136 |
* Mon Apr 24 2006 John Pye <john.pye@student.unsw.edu.au> |
137 |
- Modified for removed dir in pygtk source hierachy |
138 |
|
139 |
* Thu Apr 04 2006 John Pye <john.pye@student.unsw.edu.au> |
140 |
- First RPM package for new SCons build |