/[ascend]/trunk/ascend.spec
ViewVC logotype

Contents of /trunk/ascend.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1412 - (show annotations) (download)
Mon Apr 23 13:55:28 2007 UTC (17 years, 6 months ago) by jpye
File size: 6071 byte(s)
Fixed problem with Driver.c in ABSOLUTE_PATHS case.
Updated changelog and spec file for new 0.9.5.108 release.
1 Name: ascend
2 Summary: ASCEND modelling environment
3 Version: 0.9.5.108
4
5 # Use release 0.* so that other users can do patch releases with a higher number
6 # and still have the update occur automatically.
7 Release: 0%{?dist}
8
9
10 License: GPL
11 Group: Applications/Engineering
12 Source: ascend-0.9.5.108.tar.bz2
13 URL: http://ascend.cheme.cmu.edu/
14
15 Prefix: %{_prefix}
16 Packager: John Pye
17 Vendor: Carnegie Mellon University
18 BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20 %description
21 ASCEND IV is both a large-scale object-oriented mathematical
22 modeling environment and a strongly typed mathematical modeling
23 language. Although ASCEND has primarily been developed by Chemical
24 Engineers, great care has been exercised to assure that it is
25 domain independent. ASCEND can support modeling activities in
26 fields from Architecture to (computational) Zoology.
27
28 #----------build dependencies------------
29
30 # ...general
31 BuildRequires: scons >= 0.96.92
32 BuildRequires: bison >= 2.0
33 BuildRequires: flex >= 2.5.4
34 BuildRequires: swig >= 1.3.24
35 BuildRequires: gcc-gfortran
36 BuildRequires: libgfortran
37 BuildRequires: blas-devel
38 BuildRequires: sundials >= 2.2.0
39 BuildRequires: conopt >= 3.14
40
41 # ...pygtk
42 BuildRequires: python-devel >= 2.4
43
44 # ... tcl/tk
45 BuildRequires: tk-devel >= 8.3, tcl-devel >= 8.3
46 BuildRequires: tktable < 2.10, tktable >= 2.8
47
48 # ... GNOME
49 BuildRequires: desktop-file-utils
50
51 #-----------runtime dependencies-----------
52
53 # ...general
54 Requires: gtksourceview
55 Requires: blas
56 # sundials will be statically linked
57
58 # ...pygtk
59 Requires: python >= 2.4
60 Requires: pygtk2 >= 2.6
61 Requires: pygtk2-libglade
62 Requires: python-matplotlib
63 Requires: numpy
64 Requires: ipython
65
66 # ...tcl/tk
67 Requires: xgraph >= 11
68 Requires: tcl >= 8.3
69 Requires: tk >= 8.3
70 Requires: tktable < 2.10, tktable >= 2.8
71
72 #------------------------------------------
73
74 Provides: ascend-gui
75
76 # for the moment we'll just make one big super-package, to keep things
77 # simple for end-users.
78
79 #%package -n ascend-python
80 #Version: 0.9.5.108
81 #Summary: PyGTK user interface for ASCEND
82 #Group: Applications/Engineering
83 #
84 #%description -n ascend-python
85 #PyGTK user interface for ASCEND. This is a new interface that follows GNOME
86 #human interface guidelines as closely as possible. It does not as yet provide
87 #access to all of the ASCEND functionality provided by the Tcl/Tk interface.
88 #
89 #%package -n ascend-tcltk
90 #Version: 0.9.5.108
91 #Summary: Tcl/Tk user interface for ASCEND
92 #Group: Applications/Engineering
93 #
94 #%description -n ascend-tcltk
95 #Tcl/Tk user interface for ASCEND. This is the original ASCEND IV interface
96 #and is a more complete and mature interface than the alternative PyGTK
97 #interface. Use this interface if you need to use ASCEND *.a4s files or other
98 #functionality not provided by the PyGTK interface.
99
100 %prep
101 %setup -q -n ascend-0.9.5.108
102
103 %build
104 scons %{_smp_mflags} DEFAULT_ASCENDLIBRARY=%{_datadir}/ascend/models \
105 INSTALL_ROOT=%{buildroot} \
106 INSTALL_PREFIX=%{_prefix} \
107 INSTALL_SHARE=%{_datadir} \
108 INSTALL_BIN=%{_bindir} \
109 INSTALL_INCLUDE=%{_includedir} \
110 WITH_SOLVERS=QRSLV,LSOD,CMSLV,IDA,LRSLV,CONOPT \
111 ABSOLUTE_PATHS=1 \
112 pygtk tcltk
113
114 %install
115 rm -rf %{buildroot}
116 scons %{_smp_mflags} install
117
118 # Install menu entry for PyGTK interface, gtksourceview syntax highlighting, and MIME definition
119 pushd pygtk/gnome
120 install -m 644 -D ascend.desktop %{buildroot}/%{_datadir}/applications/ascend.desktop
121 install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/ascend-app.png
122 install -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend.png
123 install -m 644 -D ascend.xml %{buildroot}/%{_datadir}/mime/packages/ascend.xml
124 popd
125 pushd tools/gedit
126 install -m 644 -D ascend.lang %{buildroot}/%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang
127 popd
128
129 # Install menu entry for Tcl/Tk interface
130 pushd tcltk/gnome
131 install -m 644 -D ascend4.desktop %{buildroot}/%{_datadir}/applications/ascend4.desktop
132 install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/ascend4-app.png
133 install -m 644 -D ascend4.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend4.png
134 popd
135
136 %clean
137 rm -rf %{buildroot}
138
139 %post
140 update-desktop-database
141 update-mime-database /usr/share/mime
142
143 %postun
144 update-desktop-database
145 update-mime-database /usr/share/mime
146
147 %files
148 %defattr(-, root, root)
149 %doc INSTALL.txt LICENSE.txt
150 %{_datadir}/ascend/book.pdf
151
152 %{_bindir}/ascend-config
153 %{_datadir}/ascend/models
154 %{_libdir}/libascend.so
155 %{_datadir}/mime/packages/ascend.xml
156 %{_datadir}/gtksourceview-1.0/language-specs/ascend.lang
157
158 # %package -n ascend-python
159 %{_bindir}/ascend
160 %{_datadir}/ascend/*.py
161 %{_datadir}/ascend/*.pyc
162 %{_datadir}/ascend/*.pyo
163 %{_datadir}/ascend/glade
164 %{_datadir}/ascend/_ascpy.so
165 %{_datadir}/applications/ascend.desktop
166 %{_datadir}/icons/ascend-app.png
167 %{_datadir}/icons/hicolor/64x64/ascend.png
168
169 # %package -n ascend-tcltk
170 %{_bindir}/ascend4
171 %{_datadir}/ascend/tcltk
172 %{_libdir}/libascendtcl.so
173 %{_datadir}/applications/ascend4.desktop
174 %{_datadir}/icons/ascend4-app.png
175 %{_datadir}/icons/hicolor/64x64/ascend4.png
176
177 # %package -b ascend-devel
178 %{_includedir}/compiler
179 %{_includedir}/general
180 %{_includedir}/utilities
181 %{_includedir}/solver
182 %{_includedir}/linear
183 %{_includedir}/integrator
184 %{_includedir}/system
185
186 %changelog
187 * Mon Apr 23 2007 John Pye <john.pye@student.unsw.edu.au> 0.9.5.108
188 - File ascend.lang has moved.
189 - book.pdf is included in package.
190 - some header files have been moved.
191
192 * Fri Jul 28 2006 John Pye <john.pye@student.unsw.edu.au>
193 - Added CONOPT support
194
195 * Wed Jul 12 2006 John Pye <john.pye@student.unsw.edu.au>
196 - Fixed fortran linking
197 - Removed ccache dependency
198 - Added xgraph dependency
199 - Added 'include' files plus 'ascend-config' script
200
201 * Thu Jun 01 2006 John Pye <john.pye@student.unsw.edu.au>
202 - Add Tcl/Tk interface to GNOME menu
203
204 * Tue May 02 2006 John Pye <john.pye@student.unsw.edu.au>
205 - Break out ascend-core, ascend-python and ascend-tcltk packages.
206
207 * Mon Apr 24 2006 John Pye <john.pye@student.unsw.edu.au>
208 - Modified for removed dir in pygtk source hierachy
209
210 * Thu Apr 04 2006 John Pye <john.pye@student.unsw.edu.au>
211 - First RPM package for new SCons build

john.pye@anu.edu.au
ViewVC Help
Powered by ViewVC 1.1.22