/[ascend]/trunk/ascend.spec
ViewVC logotype

Annotation of /trunk/ascend.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 561 - (hide annotations) (download)
Thu May 4 07:35:43 2006 UTC (18 years, 7 months ago) by johnpye
File size: 4273 byte(s)
Changes to detection of TkTable. TkTable detection was not possible
on FC5 due to the provided tktable package not coming with header
files, and no tktable-devel being offered. Hence static linkage
to Tktable is not possible. Maybe it's not a great idea anyway.
Also modified and updated the DistTar builder for SCons.
Modified SConstruct to allow Tcl/Tk 8.4 to be used.
Modified ascend.spec.in to use system-standard version of Tcl/Tk 8.4.
1 johnpye 439 Name: ascend
2 johnpye 555 Summary: ASCEND modelling environment - shared library and model files.
3 johnpye 554 Version: 0.9.5.90
4 johnpye 439
5     # Use release "0" so that distro-released versions will override ours.
6     Release: 0.jdpipe
7    
8     License: GPL
9 johnpye 555 Group: Applications/Engineering
10 johnpye 442 Source: %{name}-%{version}.tar.bz2
11 johnpye 439 URL: http://inkscape.sourceforge.net/
12    
13     Prefix: %{_prefix}
14 johnpye 547 Packager: John Pye
15     Vendor: Carnegie Mellon University
16 johnpye 439 BuildRoot: %{_tmppath}/%{name}-%{version}-root
17    
18 johnpye 446 BuildRequires: python >= 2.4, python-devel
19 johnpye 547 BuildRequires: scons >= 0.96.1
20 johnpye 446 BuildRequires: bison, flex
21     BuildRequires: swig >= 1.3.24
22     BuildRequires: desktop-file-utils
23 johnpye 561 BuildRequires: tk-devel < 8.5
24     BuildRequires: tcl-devel < 8.5
25     BuildRequires: tktable < 2.10, tktable >= 2.8
26 johnpye 446
27 johnpye 439 Requires(post): desktop-file-utils
28     Requires(postun): desktop-file-utils
29    
30 johnpye 440 Requires: python >= 2.4
31     Requires: pygtk2 >= 2.6, pygtk2-libglade
32     Requires: python-matplotlib, python-numeric
33 johnpye 446 Requires: gtksourceview
34     Requires: make
35 johnpye 547 Requires: gcc
36 johnpye 440
37 johnpye 439 %description
38     ASCEND IV is both a large-scale object-oriented mathematical
39     modeling environment and a strongly typed mathematical modeling
40     language. Although ASCEND has primarily been developed by Chemical
41     Engineers, great care has been exercised to assure that it is
42     domain independent. ASCEND can support modeling activities in
43     fields from Architecture to (computational) Zoology.
44    
45 johnpye 555 #%package -n ascend-python
46     #Version: 0.9.5.90
47     #Summary: PyGTK user interface for ASCEND
48     #Group: Applications/Engineering
49     #
50     #%description -n ascend-python
51     #PyGTK user interface for ASCEND. This is a new interface that follows GNOME
52     #human interface guidelines as closely as possible. It does not as yet provide
53     #access to all of the ASCEND functionality provided by the Tcl/Tk interface.
54     #
55     #%package -n ascend-tcltk
56     #Version: 0.9.5.90
57     #Summary: Tcl/Tk user interface for ASCEND
58     #Group: Applications/Engineering
59     #
60     #%description -n ascend-tcltk
61     #Tcl/Tk user interface for ASCEND. This is the original ASCEND IV interface
62     #and is a more complete and mature interface than the alternative PyGTK
63     #interface. Use this interface if you need to use ASCEND *.a4s files or other
64     #functionality not provided by the PyGTK interface.
65    
66 johnpye 439 %prep
67 johnpye 555 %setup -q
68 johnpye 439
69     %build
70 johnpye 561 scons %{?_smp_mflags} DEFAULT_ASCENDLIBRARY=%{_datadir}/ascend/models INSTALL_ROOT=%{buildroot} INSTALL_PREFIX=%{_prefix} INSTALL_DATA=%{_datadir} INSTALL_BIN=%{_bindir} INSTALL_INCLUDE=%{_incdir} WITH_PYTHON=1 WITH_TCLTK=1 TCL=/usr TCL_LIB=tcl8.4 TK_LIB=tk8.4
71 johnpye 439
72     %install
73     rm -rf %{buildroot}
74 johnpye 554 scons %{?_smp_mflags} DEFAULT_ASCENDLIBRARY=%{_datadir}/ascend/models INSTALL_ROOT=%{buildroot} INSTALL_PREFIX=%{_prefix} INSTALL_DATA=%{_datadir} INSTALL_BIN=%{_bindir} INSTALL_INCLUDE=%{_incdir} WITH_PYTHON=1 WITH_TCLTK=1 install
75 johnpye 439
76 johnpye 532 pushd pygtk/gnome
77 johnpye 447 install -o root -g root -m 644 -D ascend.desktop %{buildroot}/%{_datadir}/applications/ascend.desktop
78     install -o root -g root -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/ascend-app.png
79     install -o root -g root -m 644 -D ascend.png %{buildroot}/%{_datadir}/icons/hicolor/64x64/ascend.png
80     install -o root -g root -m 644 -D ascend.xml %{buildroot}/%{_datadir}/mime/packages/ascend.xml
81     install -o root -g root -m 644 -D ascend.lang %{buildroot}/%{_datadir}/gtksourceview-1.0/language-specs/ascend.lang
82     popd
83    
84 johnpye 439 %clean
85     rm -rf %{buildroot}
86    
87 johnpye 448 %post
88     update-desktop-database
89     update-mime-database /usr/share/mime
90    
91     %postun
92     update-desktop-database
93     update-mime-database /usr/share/mime
94    
95 johnpye 439 %files
96     %defattr(-, root, root)
97 johnpye 561 %doc INSTALL.txt LICENSE.txt
98 johnpye 554 %{_datadir}/applications/ascend.desktop
99 johnpye 557 %{_datadir}/ascend/models
100 johnpye 554 %{_libdir}/libascend.so
101    
102 johnpye 555 # %package -n ascend-python
103 johnpye 439 %{_bindir}/ascend
104 johnpye 448 %{_datadir}/gtksourceview-1.0/language-specs/ascend.lang
105     %{_datadir}/icons/ascend-app.png
106     %{_datadir}/icons/hicolor/64x64/ascend.png
107     %{_datadir}/mime/packages/ascend.xml
108 johnpye 557 %{_datadir}/ascend/*.py
109     %{_datadir}/ascend/glade
110 johnpye 439
111 johnpye 555 # %package -n ascend-tcltk
112 johnpye 554 %{_bindir}/ascend4
113     %{_datadir}/ascend/tcltk
114     %{_libdir}/libascendtcl.so
115 johnpye 448
116 johnpye 439 %changelog
117 johnpye 554 * Tue May 02 2006 John Pye <john.pye@student.unsw.edu.au>
118     - Break out ascend-core, ascend-python and ascend-tcltk packages.
119    
120 johnpye 532 * Mon Apr 24 2006 John Pye <john.pye@student.unsw.edu.au>
121     - Modified for removed dir in pygtk source hierachy
122    
123 johnpye 439 * Thu Apr 04 2006 John Pye <john.pye@student.unsw.edu.au>
124     - First RPM package for new SCons build

john.pye@anu.edu.au
ViewVC Help
Powered by ViewVC 1.1.22